Stephenson’s crystal goat milk problem

SoapMakingForum

Help Support SoapMakingForum:

Craftyhands

Member
Joined
Mar 26, 2020
Messages
12
Reaction score
4
Location
Florida
I used the dbl boiler method and this happened. I am new to soap making but have been making M&P since last year and never had this problem. What’s happening to the base? Hopefully, someone can tell me. It gooped up before it melted. My conclusion: I am staying away from Stephenson’s. I am attaching two pics to show what keeps happening to it. Is it bad base? by the way, the shadow is my phone...oops.ED451926-A42F-4C48-92F8-C978C5C4B61C.jpegF2216606-269A-4380-898E-0E7FABF0530F.jpeg I’m stumped.
 

Obsidian

Well-Known Member
Joined
Jun 18, 2013
Messages
9,621
Reaction score
6,869
Location
Idaho, USA
I would email the company you got this from, maybe its a bad batch.
 

Jersey Girl

Supporting Member
Joined
Jan 11, 2020
Messages
608
Reaction score
900
Location
New Jersey
I’ve never used Stephenson’s base but I’ve never had that happen when using a double boiler for M&P. Seems like something isn’t right with that batch of base.
 

Craftyhands

Member
Joined
Mar 26, 2020
Messages
12
Reaction score
4
Location
Florida
First time using this brand for me. Think I will stick with WSP & Brambleberry brands.
 

Obsidian

Well-Known Member
Joined
Jun 18, 2013
Messages
9,621
Reaction score
6,869
Location
Idaho, USA
Stephensons is a highly recommended brand, something must be wrong.
 

Arimara

Supporting Member
Joined
Sep 29, 2015
Messages
2,998
Reaction score
1,999
Can you post a pic of the packaging with the label or is that gone? I heard that brand was one of the good ones so I'd probably call the company up.
 
Top