DOS...already?!

Soapmaking Forum - Soap & Candle Forums

Help Support Soapmaking Forum - Soap & Candle Forums:

EllieMae

Well-Known Member
Joined
Nov 26, 2019
Messages
71
Reaction score
126
Location
Toronto, ON
I did my first swirl attempt earlier this week (Wednesday - 2 days ago) and added lavender flowers for the first time. Just checked on it in the mold (first time since pouring) and it appears I already have DOS (pretty sure...), specifically around the lavender flowers. Is this typical when adding dried elements to CP or did I do something horribly wrong?
3CBBED52-1297-4719-9A92-45D68DCCEEEF.jpeg
 

IrishLass

Staff member
Admin
Moderator
Supporting Member
Joined
Feb 11, 2008
Messages
17,533
Reaction score
11,438
Location
Right here, silly!
Happy news, EllieMae.....That's not DOS. Those spots are what typically happens when flower petals (fresh or dried) are added to soap. They react with the high pH of the lye and turn brown. That's why I never add flower petals to my soap.


IrishLass :)
 

EllieMae

Well-Known Member
Joined
Nov 26, 2019
Messages
71
Reaction score
126
Location
Toronto, ON
Happy news, EllieMae.....That's not DOS. Those spots are what typically happens when flower petals (fresh or dried) are added to soap. They react with the high pH of the lye and turn brown. That's why I never add flower petals to my soap.


IrishLass :)
Oh thank goodness!!! I was really scratching my head wondering how on earth DOS would have shown up ALREADY!

This will probably be my first and last batch with flowers. For both this reason and the less than perfect cut lol.

Thank you!!!!
 

Latest posts

Top