1. We are helping test out a new project for soapmakers. Soapmaking Friend. If you are interested in providing feedback and help guide this project to include all you want to see in a recipe builder and calculator please PM an Admin or post in the Announcements forum. Your feedback is really needed!
    Dismiss Notice
  2. Dismiss Notice

Forum changes (put all issues found on this thread)

Discussion in 'SMF Announcements, Comments, Help & Rules' started by SaltedFig, Jan 30, 2018.

Help Support Soapmaking Forum by donating:

  1. Oct 29, 2018 #501

    Relle

    Relle

    Relle

    Administrator & Bunny Fanatic Staff Member Admin

    Joined:
    Sep 23, 2010
    Messages:
    8,763
    Likes Received:
    2,235
    All fixed for me now, I can click on the side bar for new posts :thumbs:.
     
  2. Oct 31, 2018 #502

    Relle

    Relle

    Relle

    Administrator & Bunny Fanatic Staff Member Admin

    Joined:
    Sep 23, 2010
    Messages:
    8,763
    Likes Received:
    2,235
    Side bar new posts not working again :mad:.
     
  3. Oct 31, 2018 #503

    SaltedFig

    SaltedFig

    SaltedFig

    Lifetime Supporter

    Joined:
    Feb 25, 2017
    Messages:
    1,494
    Likes Received:
    1,288
    Location:
    Australia
    It works for me using the desktop (the sidebar that is), but on the mobile device it doesn't work (and hasn't for days).
     
  4. Oct 31, 2018 #504

    Relle

    Relle

    Relle

    Administrator & Bunny Fanatic Staff Member Admin

    Joined:
    Sep 23, 2010
    Messages:
    8,763
    Likes Received:
    2,235
    Maybe, that's what's happening to me.
     
  5. Oct 31, 2018 #505

    Angie

    Angie

    Angie

    Staff Member Admin

    Joined:
    Nov 6, 2013
    Messages:
    1,008
    Likes Received:
    289
    Location:
    N. AL
    Yesterday we found an element of the server software needed updating. It was done late evening into week hours. It is fixed now, but there may be a touch of software tweaking today once the developer can check on things.
    Sorry it was a bummer, but we just happened to discover it about lunch time yesterday.
     
  6. Nov 3, 2018 #506

    SaltedFig

    SaltedFig

    SaltedFig

    Lifetime Supporter

    Joined:
    Feb 25, 2017
    Messages:
    1,494
    Likes Received:
    1,288
    Location:
    Australia
    The keyboard shortcut "Ctrl-X", which is used to cut a selected segment of text out to the clipboard, causes unexpected cursor location and display changes for larger volumes of text (when scrolling is required).

    The nature of the change varies - sometimes cursor focus and display of text are both shifted to the end of the editor-box, sometimes the the cursor focus stays in the same location but the display shifts to the end and sometimes the cursor focus and display stay in the same location, making the error unpredictable.

    My testing suggests it is related to line breaks ... this link suggests where the problem might be:
    https://xenforo.com/community/threads/ctrl-x-or-right-click-cut-do-not-work-in-editor.138635/
     
  7. Nov 9, 2018 #507

    earlene

    earlene

    earlene

    Grandmother & Soaper Lifetime Supporter

    Joined:
    Apr 30, 2016
    Messages:
    4,543
    Likes Received:
    4,044
    Location:
    Western Illinois, USA
    Uploading photos to my gallery using my third party photo hosting isn't an option currently. All I can do apparently is upload directly from my computer. Is this a glitch that needs fixing or a change?

    photo upload glitch.JPG
     
  8. Nov 9, 2018 #508

    Angie

    Angie

    Angie

    Staff Member Admin

    Joined:
    Nov 6, 2013
    Messages:
    1,008
    Likes Received:
    289
    Location:
    N. AL

    upload_2018-11-9_15-45-6.png

    I think I have you fixed up now.
     
  9. Nov 9, 2018 #509

    Angie

    Angie

    Angie

    Staff Member Admin

    Joined:
    Nov 6, 2013
    Messages:
    1,008
    Likes Received:
    289
    Location:
    N. AL
    I read that thread and it said it was fixed. But when I highlight a section of a post it automatically goes to a quote status, before I can even use the Control X. So, isn't the function working better as it cuts for pasting before you control X?
     

    Attached Files:

  10. Nov 9, 2018 #510

    SaltedFig

    SaltedFig

    SaltedFig

    Lifetime Supporter

    Joined:
    Feb 25, 2017
    Messages:
    1,494
    Likes Received:
    1,288
    Location:
    Australia
    Something has changed, because it is working much better now (no skipping to the end of the text when control X is used, which is really good).

    I will come back in a little while - it looks like it is still being worked on :)

    (As I was typing, using Crtl-V to paste went from adding a line return on paste, to dropping the trailing space, which is where it is currently at)
     
    Last edited: Nov 9, 2018
  11. Nov 9, 2018 #511

    Angie

    Angie

    Angie

    Staff Member Admin

    Joined:
    Nov 6, 2013
    Messages:
    1,008
    Likes Received:
    289
    Location:
    N. AL
    We did get something else worked on last evening that may have had a side effect to fix things for you.
     
  12. Nov 9, 2018 #512

    SaltedFig

    SaltedFig

    SaltedFig

    Lifetime Supporter

    Joined:
    Feb 25, 2017
    Messages:
    1,494
    Likes Received:
    1,288
    Location:
    Australia
    Fair enough - that worked out well then! :)

    Then I'll change the report to say that when text is pasted from the clipboard (Ctrl-V), then the trailing line return or space is dropped.

    Details:
    I can see that the space following a word is highlighted and cut when I use Ctrl-Z, and it is in the clipboard (I can paste the text, including the trailing space, in notepad), so the error is occuring during the paste (Crtl-V).

    When I select a whole paragraph to cut, by selecting from the beginning of the line and highlighting downwards (to copy the line returns as well), the cursor should be sitting at the beginning of the next line after a paste - again it does this when pasting to notepad, but here the line return is lost and the cursor sits at the end of the sentence.

    These issues are much more minor than a complete cursor jump, but it is acting differently to the standard.
     
  13. Nov 10, 2018 #513

    earlene

    earlene

    earlene

    Grandmother & Soaper Lifetime Supporter

    Joined:
    Apr 30, 2016
    Messages:
    4,543
    Likes Received:
    4,044
    Location:
    Western Illinois, USA

    Thank you, it is working again. Much appreciated!
     
    Angie likes this.
  14. Nov 13, 2018 #514

    SaltedFig

    SaltedFig

    SaltedFig

    Lifetime Supporter

    Joined:
    Feb 25, 2017
    Messages:
    1,494
    Likes Received:
    1,288
    Location:
    Australia
    I have an idea for you! :)

    Problem: Really old posts can show up when "New Posts" is clicked ... they all show up if they are unread, regardless of age.
    (It is a regular occurrence to have a new/returning members to not even realise they have posted in reply to a very old post until the moment they are told it is not acceptable by an admin.)

    Suggestion: Could we have the new posts have a time limit on the search results (perhaps displaying posts from the last year, or similar), with an option to display older posts as an additional search option at the bottom of the results page?
    (Having a bit of a limit, with an option to search older "new posts" would stop the admin staff from needing to intervene as often, and new/returned members wouldn't have to face the embarrassment of being pulled up for necroposting.)
     

Share This Page